Home > Gnome Evolution, GNU/Linux, Ubuntu at work > Gnome Evolution Updates for Karmic

Gnome Evolution Updates for Karmic


The latest unstable release of Gnome Evolution 2.29.3 was released yesterday with an updated 0.29.3 mapi plugin and provides a marked improvement over the current stable release in Ubuntu Karmic 9.10 (i.e. Evolution 2.28.1 and evolution-mapi 0.28.0).

The roadmap for releases of the latest Gnome components is shown here

I have tested the 2.29.3 release for Evolution against the Exchange 2007 server and can report that the Global Address List is fully functional and the email part of Evolution works well with the mapi plugin.  Unfortunately, the same cannot be said of the calendar functionality which had a caniption and froze on any attempt to access.

So the good news is, you can use Evolution cleanly to talk to an Exchange 2007 server now as long as you only want to use email.

I will document the steps required for anyone adventurous enough and prepared to deal with what is code under active development.

Advertisements
  1. December 2, 2009 at 05:49

    I am very interested in what steps you took. I’m actively watching the progress of the mapi plugin, so I would like to see how close the bleeding edge is getting.

    Thanks!

    • gurrier
      December 2, 2009 at 18:53

      Matt,

      Well email looks good. I am investigating now whether there is a disconnection issue over time.
      Global Address List (GAL) works well and there are no issues emailing individuals on your own domain.

      However, Calendar still needs some work and is basically still a work in progress.
      The Gnome Evolution Developers have made good progress with this release so hopefully they will see the bugs raised against 2.29.3 for the next release on Dec 14th.

      Cheers,

      gurrier

  2. Dan
    December 2, 2009 at 09:41

    I am interested in the update as well. I put then patch on dated Nov 3. Will this patch need to be removed. I am a newbe and will need some assistance in removing the Nov. 3 patch.

    • gurrier
      December 3, 2009 at 08:41

      Dan.

      I was able to just compile over the top so it looks like removal is not an issue.
      More details to come once I have more time.

      Regards,

      gurrier.

  3. Pete
    December 11, 2009 at 07:52

    Hi gurrier,

    Any idea when you will have the write up on upgrading to evolution 2.93 on Ubuntu 9.10 complete? I would like to try this. I get hung on ./configure at checking for GNOME_PLATFORM. This is like my 6th day of using linux so I probably shouldn’t be doing this but I can follow instructions if I can find them.

    Thanks,
    Pete

    • gurrier
      December 11, 2009 at 23:35

      Pete,

      Just posted. You may have been missing some prerequisites.

      Regards,

      gurrier

  4. Pete
    December 12, 2009 at 00:49

    AWESOME! I will try this shortly. I just looked at the README again and there is a whole section on dependencies. I don’t know how I missed that. Is that where you got your list of prereqs from?

    Thanks,
    Pete

    • gurrier
      December 13, 2009 at 20:49

      I just found the pre-reqs by trial and error on the Karmic Koala machine I built it on.
      Hope things worked out ok for you?

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: